Slack Issues

Incident Report for Dartmouth College

Resolved

Slack has updated their status to normal. All issues should be resolved.
Posted May 14, 2026 - 12:20 EDT

Investigating

Slack is investigating degraded performance. Affected functionality includes messaging, integrations, workflows, and files. We will follow up as additional information is available from the vendor.
Posted May 14, 2026 - 11:10 EDT
This incident affected: Academic Services and Administrative Services.